Last updated: 13-11-2025
Even with an active Articulate 360 license, you may not be able to develop, and you might see the message “Trial expired” when signing in through your browser.
Below you’ll find the possible causes and how to solve them.
Causes
Seat
With an Articulate 360 Teams license, creator licenses are not automatically assigned to all team members. Check whether a seat has actually been assigned to you.
More information can be found here:
Creator licenses within Articulate 360 Teams
Server
Articulate has two separate servers:
EU server:
https://360.eu.articulate.com/US server:
https://360.articulate.com/
These servers do not communicate with each other.
If you once requested a trial on the US server, an Articulate ID will continue to exist there — even if you now have an active license on the EU server (or vice versa).
When requesting a new trial, the EU server is now used by default, whereas the US server was used previously. You can still choose between EU and US manually.
Solutions
Creator
Check whether you are part of an Articulate 360 Teams license and whether the email address you use to sign in has been added as a Creator. Only then can you access the authoring tools.
Server
Check the URL in your browser’s address bar when you see the message “Trial expired.”
If you see https://360.eu.articulate.com/, sign out and try signing in via https://360.articulate.com/.
If you see https://360.articulate.com/, sign out and try signing in via https://360.eu.articulate.com/.
This helps you quickly determine which server your license is active on.
Tip: If you requested your license specifically for the EU server but still see “Trial expired” at https://360.eu.articulate.com/, contact sales@courseware.nl.
Access to old trial content
If you once had a trial on one server (for example US) and now have an active license on the other (EU), you will no longer be able to open the Rise 360 content you created during that trial. The servers are completely separate, so content cannot be transferred between them.
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